JW Player billing page and checkout partial outage
Incident Report for JW Player
Resolved
Third party billing provider issues have been resolved and JW Player billing and checkout pages are functional again. Thank you for your patience.
Posted Aug 11, 2017 - 13:58 UTC
Identified
Our third party billing and payment provider is currently experiencing issues which is impacting the JW Player billing page and may impact self service order checkouts. We are monitoring the status of our provider and will update as soon as possible.
Posted Aug 11, 2017 - 13:38 UTC