Freewheel ad serving issue

Incident Report for JW Player

Update

We are currently investigating an issue with serving Freewheel ads on the latest cloud-hosted player version.
If this affects you, as a temporary workaround, please use the “Previous” release via the Player page.
Posted May 28, 2025 - 15:18 UTC

Investigating

We are currently investigating an issue with serving Freewheel ads on the latest cloud-hosted player version.
Posted May 28, 2025 - 13:49 UTC
This incident affects: Cloud Hosted Players.