Elevated latency on Low Latency Live Streams

Incident Report for JW Player

Resolved

This incident has been resolved.
Posted Mar 14, 2025 - 21:47 UTC

Update

As of 20:12 UTC, the team has implemented a fix and latency has returned to normal. At this point we expect all low latency live streams to be fully operational.
Posted Mar 14, 2025 - 20:49 UTC

Monitoring

The issue has been identified and a fix is being implemented.
Posted Mar 14, 2025 - 20:26 UTC

Identified

Third party provider issue impacting Instant Live.
Posted Mar 14, 2025 - 20:06 UTC
This incident affected: Instant Live and Media Delivery.