Payment UI Outage
Incident Report for JW Player
Resolved
This incident has been resolved.
Posted Mar 27, 2024 - 21:12 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 27, 2024 - 21:02 UTC
Investigating
We are experiencing an issue with our Payment UI preventing check out for some customers. Our engineers are currently investigating the issue.
Posted Mar 27, 2024 - 20:54 UTC
This incident affected: Subscription & Identity Management.