Dashboard Media Visibility Issues

Incident Report for JW Player

Resolved

The issue preventing recently uploaded media from appearing in the JW Player dashboard has been resolved. All media entries are now visible and searchable.
Posted Feb 19, 2025 - 03:35 UTC

Investigating

We are currently investigating reports of recently uploaded media not appearing in the JW Player dashboard. While media remains accessible via direct URLs (e.g., ⁠https://cdn.jwplayer.com/v2/media/) or (https://dashboard.jwplayer.com/p//media/), users cannot search for or view these entries through the dashboard interface.
Posted Feb 19, 2025 - 03:25 UTC
This incident affected: Dashboard.