Video Storage Service Elevated Error Rate

Incident Report for JW Player

Resolved

This incident has been resolved.
Posted Jul 18, 2025 - 19:05 UTC

Update

We are continuing to monitor for any further issues.
Posted Jul 18, 2025 - 16:35 UTC

Monitoring

Systems are recovering and we are being monitored
Posted Jul 18, 2025 - 16:27 UTC

Identified

Third party provider issue impacting Instant Live.
Posted Jul 18, 2025 - 15:36 UTC
This incident affected: Instant Live and Media Delivery.