Broadcast Live Events within the US-East-1 region are not being created as expected

Incident Report for JW Player

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 23:10 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 22:28 UTC

Monitoring

All systems are now working, and we are going to continue to monitor the situation.
Posted Oct 20, 2025 - 22:27 UTC

Update

We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 21:43 UTC

Update

We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 21:14 UTC

Update

We are continuing to monitor this issue.
Posted Oct 20, 2025 - 20:55 UTC

Update

We are continuing to monitor this issue.
Posted Oct 20, 2025 - 19:45 UTC

Update

We are starting to see service related issues return due to the ongoing issues with AWS's US-EAST-1 Region.

We are continuing to monitor this issue.
Posted Oct 20, 2025 - 15:43 UTC

Identified

We are aware of an issue which is causing some Broadcast live Streams using the US-East region from creating as expected due to the downgraded behaviour in AWS's US-EAST-1 Region.
Posted Oct 20, 2025 - 15:27 UTC
This incident affected: Dashboard, Broadcast Live, Instant Live, Media Delivery, Server-side Ads, and Video Management.