Custom Reports and Analytics Experiencing Issues

Incident Report for JW Player

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 23:22 UTC

Monitoring

We have applied a fix and are monitoring performance. We will provide updates as they are delivered by the engineering team.
Posted Oct 21, 2025 - 22:50 UTC

Update

We are continuing to work on a fix for this issue.
Posted Oct 21, 2025 - 21:58 UTC

Identified

We’ve identified the issue and are working to restore services.
Posted Oct 21, 2025 - 21:10 UTC

Investigating

We are currently investigating this issue.
Posted Oct 21, 2025 - 20:35 UTC
This incident affected: Analytics.