DRM Issues affecting US and Asia regions

Incident Report for JW Player

Resolved

This incident has been resolved.
Posted Mar 23, 2026 - 15:44 UTC

Update

We have applied a fix and are monitoring performance
Posted Mar 23, 2026 - 15:17 UTC

Monitoring

Increased latency and 5xx on DRM platform requests
Posted Mar 23, 2026 - 15:14 UTC
This incident affected: Studio DRM.