Broadcast Live | EU Region is experiencing unexpected buffering

Incident Report for JW Player

Resolved

We have increased the levels of cache within the Europe region and all monitoring has returned to normal.
Posted Aug 08, 2025 - 11:04 UTC

Investigating

The EU Region of Broadcast Live is experiencing long fragment and manifest fetch times, leading to unexpected buffering.

We are currently investigating this issue and will provide more updates shortly.

In the meantime, we recommend to use the North America region for any streams.
Posted Aug 08, 2025 - 09:48 UTC
This incident affected: Broadcast Live.