Increase in error rates for image delivery

Incident Report for JW Player

Resolved

This incident has been resolved.
Posted Nov 20, 2025 - 21:27 UTC

Update

We are continuing to work on a fix for this issue.
Posted Nov 20, 2025 - 18:56 UTC

Identified

Third party provider issue impacting Instant Live.
Posted Nov 20, 2025 - 17:50 UTC
This incident affected: Instant Live and Media Delivery.