Series services not fully functional

Incident Report for JW Player

Resolved

This incident has been resolved.
Posted Jan 22, 2025 - 17:07 UTC

Identified

The series service is not fully functional at the moment. We've identified the issue and are applying a fix.
Posted Jan 22, 2025 - 17:04 UTC