Billing failures on some credit cards
Incident Report for JW Player
Resolved
Our payments processor has resolved the issue and all transactions are now properly being processed. If you attempted to check out with a new account and received an error message, please try again.
Posted 3 months ago. Jul 06, 2017 - 16:49 EDT
Identified
An issue with our payments provider is causing some credit card transactions (new and recurring) to fail. The payment processing partner is aware and investigating the root cause. The issue has been occurring intermittently since 3AM EDT (0700 UTC).
Posted 3 months ago. Jul 06, 2017 - 10:03 EDT