Delays in support email responses
Incident Report for JW Player
Resolved
This incident has been resolved.
Posted Jul 17, 2017 - 22:09 UTC
Investigating
We are currently investigating an issue with our ticketing system which is causing a delay in outgoing responses.
Posted Jul 17, 2017 - 21:05 UTC