Support site outage
Incident Report for JW Player
Resolved
We have resolved an issue with an upstream provider.
Posted Jan 15, 2018 - 13:55 UTC
Investigating
We are currently experiencing an issue with the support website support.jwplayer.com. Users can not submit a ticket or view support articles at this time.
Posted Jan 15, 2018 - 13:40 UTC